Issue Copernica servers

Incident Report for Copernica

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 11:22 CET

Investigating

We are currently experiencing difficulties on our image servers.
At this moment, it is not possible to upload images.
Our Operations department is currently investigating the underlying issue.

Our apologies for any inconvenience this may cause.
If you have any further questions, please contact us.
Posted Mar 14, 2025 - 10:32 CET
This incident affected: Webpages (Publisher and Marketing Suite, Picserver).