Statistics issue
Incident Report for Copernica
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 15:58 CET
Investigating
We are currently experiencing problems updating the statistics. The data is registered but not processed.

Our development department is currently investigating this. Once the issue is resolved, the statistics will be updated retroactively.
Posted Nov 17, 2022 - 15:25 CET
This incident affected: Webpages (Publisher and Marketing Suite).